Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Typo in the "Linux flash guide"
#11
I did that but without success.
What happens:
  • after about 1.5 sec I release the On button while keeping the side button pressed
  • the unit vibrates
  • the screen turns on (with Tux on the welcome screen)
  • I release the side button
  • the screen turns off
  • the screen turns on again (with Tux on the welcome screen), it says Powered by Linux
  • the screen changes to "Powered by Android"
  • the device boots Gemini
It always vibrates when I start it. If I keep the On button pressed for less than about 1.5 second it will not switch on.
At this point I am waiting for another bootable image. Either the image is rotten, or I didn't flash it right.

Thanks for your help anyway.
Reply
#12
I eventually flashed and got it to boot into Linux (agree with posters above that boot choice method is non-intuitive and not clearly documented, and would prefer boot menu) but can't get past initial setup screen. It shows default user "Gemini", and asks for password. Neither null password nor new user-selected password are accepted. What is default password for default user "Gemini"? And/or how how does one navigate to option to set up new user? Neither touchscreen nor keyboard seem to respond to anything except entry of password for user "Gemini", which is always rejected.
Reply
#13
The default password is: gemini
Reply
#14
Thanks! This is helpful and probably should be added to the Linux support documentation.

I also notice that the "Flashing Guide" on this site has been amended to add "never use the 'Format all + download' option in the SP Flash Tool as this erases key information stored in the NVRAM partition and can lead to a non-functional device." Helpful, but too late for me!

I have the IMEI, serial number, and "MEID" from the Gemini package sticker. Can nvram be reconstructed, or a replacement nvram supplied, or IMEI re-entered?

I had a backup of NVRAM, but after restoring it, I still get "invalid IMEI" and non-working phone/SIM functions in all firmware versions including default Google Android.  Everything that doesn't depend on the SIM still seems to work.

I suspect that by carefully following the step-by-step guide including "readback" each time I flashed the different firmware options (default Google Android, rooted Google Android and TWRP to bootstrap flashing of Lineage OS, dual-boot Google Android/Linux) I had overwriten my nvram backup file with the re-formatted null nvram from "format all + download". It wasn't clear that "format all + download" would overwrite nvram with a null partition, rather than restoring the backup along with the new firmware (the behavior I expected).

I would rather not have had to use the flash tool, and was afraid I would brick my Gemini, but that was the only way to get either Linux dual-boot (part of the expected spec for the Gemini we backed) or a device with any OS option not pwned by Google.


It's not your fault that the flash tool is non-intuitive, but is there any way to recover phone functionality?
Reply
#15
The "Format ALL" option is disabled in the tool provided by Planet, exactly for this reason.

However, resetting the IMEI is definitely possible.

Follow the information to download and flash a rooted Android OS http://support.planetcom.co.uk/index.php...id_Support

Once you boot your rooted android there are a number of ways to write back your IMEI.
The easiest is possibly to simply download a terminal app and write:

echo 'AT+EGMR=1,7,"IMEI"' > /dev/radio/pttycmd1

Once the IMEI is set, you can reflash the phone with a non-rooted Android version if you wish to do so.
Reply
#16
I rooted the Gemini and tried from a terminal:

$ su
# echo 'AT+EGMR=1,7,"IMEI"' > /dev/radio/pttycmd1

I get the response:
AT+EGMR=1,7,IMEI: not found

IMEI still shows as null.

You say, "Once the IMEI is set, you can reflash the phone with a non-rooted Android version if you wish to do so."  That's what I would like to do. I  want a non-rooted device, not a device rooted to Google. Where can I obtain an OS for the Gemini not rooted to Google? Why not offer a certified version of Lineage OS as the default on the Android side of the dual boot, and let buyers make the choice of whether to root their device to Google and whether to install some, all, or none of the Google apps?

The only tool I used was the one at:
http://support.planetcom.co.uk/download/FlashTool.zip

I tried multiple options in that tool to try to get either Lineage OS (Android) or Linux working with phone functions. Neither yet supports phone functions on the Gemini, so far as I can tell. When I gave up and re-flashed the default Google OS, the IMEI shows as null.

I only flashed the Gemini because that was necessary to try to get either open-source Android or Linux.

I backed a project for a dual-boot device with a choice of two open-source OS's, Android or Linux. Instead I got a device with only a proprietary Google OS, built on top of Android but then rooted to (pwned by) Google, and with a blog of proprietary Google bloatware and spyware with root privileges pre-installed.

I understand that some, perhaps many, buyers may want that. Maybe you should offer that Google OS -- as an option. But that's not what we backed on Indiegogo. You can't blame people who try to flash our Geminis, if that's what we have to do to try to get what we backed.

Please don't misunderstand: I am very grateful to you for supporting third-party developers by posting kernel and bootloader source code. Thank you for that, and thank you for not voiding the warranty (if there is any warranty on Indiegogo perks!) if we root our Gemini.
Reply
#17
In the command:

$ su
# echo 'AT+EGMR=1,7,"IMEI"' > /dev/radio/pttycmd1

You should replace IMEI with your actual IMEI number, keeping the quotes.

Regarding OS support, both Planet and especially the Open Source community is working on it.
The goal is indeed to have the phone stack support working on Lineage, Linux, etc., we are working towards it but we are not there yet.
We will announce when phone stack support will be ready, please stay tuned.
Reply
#18
You say, "You should replace IMEI with your actual IMEI number, keeping the quotes."

That's what I did, using the IMEI from the sticker on the Gemini box.

I get the response as follows (where IMEI is again a placeholder for the actual IMEI I entered):

sh: AT+EGMR=1,7,IMEI: not found
Reply
#19
I don't really understand what is wrong here.
I would suggest the following:

1 - Make sure your unit is really rooted. Don't forget to install "Magisk Manager" after flashing the root version.
2 - To rule out other possible issues, please install "Terminal Emulator for Android" (free)
3 - You should now be able to set the IMEI, as you can see in the attachment


Attached Files Image(s)
   
Reply
#20
Thank you! Your screenshot enabled me to find the problem. My problem resetting the IMEI from the terminal was due to a problem with the Gemini keyboard configuration.  My Gemini has US-English keyboard; default Google OS; and Gemini Keyboard app installed, updated, and configured and enabled for Gemini keyboard US-English as default. Many of the non-aphanumeric characters are mis-mapped in the terminal app.

The key combination labelled on the US-English hardware keyboard for single-quote, Fn-M, actually generated a "grave accent" in the terminal app. It looked suspicious, but plausible for a "tilted" or "curly" single quote character. And since I could find no other key combination that would produce anything that could possibly be a single-quote character, and this matched the keyboard hardware labelling, I figured it had to be the single-quote character. I was only sure it was wrong when I saw that it didn't match the appearance of the single-quote character in your screenshot.

Some other keys are also mis-mapped in the terminal (although correct in most GUI apps), but I found the other desired characters for the terminal command elsewhere on the keyboard. Fn-L is labelled on the hardware keyboard as double-quote, but actually generates semicolon in the terminal app. But this was obvious, and by trial and error I found that shift-2, which is labelled as @, actually generates double-quote in the terminal app.

Maybe you were testing with a UK or international English hardware keyboard or software option in the keyboard app, so you didn't notice this?

There are also similar keyboard mapping problems in the initial Gemini and Google setup screens, before you get to the option to change keyboard mapping.

I found no key combination that would generate single-quote in the terminal. I tried to cut and paste from another app, but couldn't find a "paste" command in the terminal app. Long-press, which pops up an edit dialog in many android apps, didn't produce any response in the terminal app.

Anon-screen keyboard would pop up in the terminal, but was unresponsive in landascape mode.

I eventually found a workaround to generate the necessary single-quote character in the terminal:

(1) Turn off "force landscape" in the Gemini app bar settings. (IMHO this should be off by default. Many apps malfunction, or fail silently, or hide essntial UI elements, when forced into landscape.)

(2) Turn the Gemini to portrait orientation.

(3) Pop up the on-screen keyboard.

(4) Enter single-quote from the on-screen keyboard in the terminal app in portait orientation.

Hope this helps anyone else who flashes over their IMEI or wants to use use terminal commands.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)