Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Can't seem to use the flash tool

Sorry for the dumb question.
I would like to try out the Linux preview on the Gemini.

My host computer is Arch Linux so I set up a win7 machine running in Virtualbox.

I installed the flash tool drivers on win7.
Then I ran the flash tool to perform a backup of the NVRAM first.
When I click Readback and restart the Gemini nothing happens, the program is supposed to detect the Gemini and start the backup, but it doesn't happen.
The screen stays like this:



USB-wise the Gemini is recognized by Windows, I can see it in the explorer. Windows reacts every time I plug or unplug the Gemini.
I even added USB filters on Virtualbox to 're-plug' the Gemini automatically.

I suppose the Gemini has to be restarted in a certain way to be detected by the flash tool. What am I doing wrong ?

Attached Files
.zip (Size: 110.88 KB / Downloads: 437)
Did you do it like described here:

in short:
1) click add before readback
2) click readback if geminiPDA is not connected
3) connect usb to PDA (left side, PDA should be powerd off, if you connect it)

it should start reading the NVRAM

PS: did not see an image, only random string
--= sailfish OS for gemini PDA =--
Thank you for your reply.
I have updated the picture (the copy-paste didn't render once posted).

I followed the steps normally but when I restart the Gemini, it simply starts Android and the flash tool doesn't budge. I saw on some videos how the progress bar should start moving while doing the NVRAM backup.

I even set up a USB filter in Virtualbox, so that the device is plugged in immediately when connected to the host computer.
I indeed hear the Windows sound when Virtualbox attaches the device, by then Android is already starting. Maybe it's a question of USB timing ?

I can't be the only one using a VM. It is a clean Win7 VM installed from original CD, but with no recent updates (no network access).

PS: I fetched the logs from the flash tools and attached them to the original post.
I see this line in the logs but not sure if this relevant to my problem:

03/18/18 17:49:16.470 BROM_DLL[3028][2848]: WARNING: EnumerateDevice(): Get friendly name failed! Err(13) (FlashToolLib/host/windows/com_enum.cpp:618)
Ok, maybe its a problem with virtual machine. You can try other usb modes, find them under Options. Virtualbox supports slow mode only if you do use the opensource driver.
Maybe its a windows version problem (I could do it with an old vista on an old hdd). Think the win drivers are XP drivers.

I do not like windows and use it with archlinux. Sometimes I need more than one try (connect disconnect PDA) to make it work (did not find the reason atm).

You are using archlinux too, hope the links can help you to use the linux SP-Flashtool:

1) download the v5.1852:
2) unzip the archive
3) make flashtool and executable
4) configure archlinux, howto at:
5) reboot archlinux
6) start
7) select at tab "download" the scatter.txt file from
8) click at "readback" add entry and double on the added entry (select where to save the file after that you need to insert the addresses manualy in the dialog after fileselection)
9) manual input for NVRAM0:
Start Address: 0x000000000ab00000
Length: 0x0000000000500000
10) click "Read Back"
11) insert usb to the powered off PDA

and try if you can readback the NVRAM0 with SP-Flashtool for linux. It works for me.
--= sailfish OS for gemini PDA =--
Thank you.
I did just that and I am making some progress. I flashed the device and the welcome screen changed. There is now Tux.

Here is what I have noticed.
I refer to the doc and your own post here
Keeping the side button key pressed does nothing.
Keeping the On key pressed brings up this screen:


And after switching on the Gemini the first time I got this screen:

I chose reboot system now (no idea if there is another better option)

Then I see Planet etc powered by Linux
And then a few moments later it is powered by Android
And then crash:

(the text says "no command")

So Linux doesn't seem to start.
I can still start Android the normal way (Control + On).

Maybe I should wait for another image to be made available. I have zero interest in Android anyway, therefore no need for a dual boot.
Very interesting: I have seen the recovery (2nd pic) only one time, too. I never ever could start it again (hold silver button until screen turns on = 3rd pic - should be recovery too). Maybe it is only available after flashing, maybe that something is missing, after a first startup.

To start Linux: press the ON key only until the screen (1st pic) comes up.

Look my posting there:

> Keeping the side button key pressed does nothing.
You should press ON until ist vibrates and keeping the side button until the screen is on = recovery = dead Android with no command, but should be like your pic2
--= sailfish OS for gemini PDA =--
So I keep the On button pressed for about 10 seconds I get the welcome screen with Tux:


After about two seconds it becomes like this:


As if it couldn't load Linux and used Android as a fallback.

Admittedly I am not experienced at flashing devices Wink
I guess I will wait for a more mature image then.

Might the information at the bottom of this thread help?

There's apparently some confusion as to which buttons to push and when and with which image.
The thing is, since the upgrade, the side button does not switch the device on anymore.

I can only use the On button, with or without keeping the Planet key pressed.
(03-22-2018, 11:39 AM)Marjorie Wrote: The thing is, since the upgrade, the side button does not switch the device on anymore.

I can only use the On button, with or without keeping the Planet key pressed.

The side button is not meant to switch on the unit, it is used to detect which partition to boot into.
You need to press the On (Esc) button to switch the unit on.
When the device boots, it will check wether the side button is pressed or not, if pressed it will boot Linux, otherwise it will boot Android.

Try press and hold the side button while restarting. You can release the side button when you see the screen turning ON again.

Forum Jump:

Users browsing this thread: 1 Guest(s)