Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GNU/Linux user-land on top of Android
#11
I added the following to my .bashrc in termux to make getting into linux easier.

linux() {
su -c "/data/data/ru.meefik.linuxdeploy/bin/linuxdeploy shell -u gemini"
}

I also edited /data/data/ru.meefik.linuxdeploy/env/include/core/net/deploy.sh

### insert this bit
echo "cleanup symlink resolver"
test -L "${CHROOT_DIR}/etc/resolv.conf" && rm "${CHROOT_DIR}/etc/resolv.conf"
### before this line
printf '' > "${CHROOT_DIR}/etc/resolv.conf"
for dns in ${dns_list}
do
echo "nameserver ${dns}" >> "${CHROOT_DIR}/etc/resolv.conf"
done

which allows the system to update the resolv.conf so that it can use DNS
Reply
#12
Thanks for describing interesting theme.
Is it possible to run program with linux UI in that way? I mean something like I mentioned here https://developer.planetcom.co.uk/showthread.php?tid=10
Reply
#13
I'm using linux deploy to start chrooted linux.
Is it possible to use /dev/graphics/fb0 to output UI on our Gemini?
Reply
#14
The Framebuffer is already opened by Android. You need something which will cooperate. Your best bet would be an X11 Server for Android which you can then target with DISPLAY=:0
Reply
#15
(06-08-2018, 03:34 PM)Beiriannydd Wrote: The Framebuffer is already opened by Android.  You need something which will cooperate.  Your best bet would be an X11 Server for Android which you can then target with DISPLAY=:0/
Simple  test cat /dev/urandom > /dev/graphics/fb0 doesn't work (you should see some distortions).
LinuxDeploy can use framebufer, but I can't mde it to work.
Reply
#16
(06-09-2018, 12:54 PM)nox Wrote:
(06-08-2018, 03:34 PM)Beiriannydd Wrote: The Framebuffer is already opened by Android.  You need something which will cooperate.  Your best bet would be an X11 Server for Android which you can then target with DISPLAY=:0/
Simple  test cat /dev/urandom > /dev/graphics/fb0 doesn't work (you should see some distortions).
LinuxDeploy can use framebufer, but I can't mde it to work.
If what I was told is accurate, no one has written a framebuffer driver for at least pure-console Linux. Might this be the issue?
Reply
#17
(06-10-2018, 02:01 PM)depscribe Wrote:
(06-09-2018, 12:54 PM)nox Wrote:
(06-08-2018, 03:34 PM)Beiriannydd Wrote: The Framebuffer is already opened by Android.  You need something which will cooperate.  Your best bet would be an X11 Server for Android which you can then target with DISPLAY=:0/
Simple  test cat /dev/urandom > /dev/graphics/fb0 doesn't work (you should see some distortions).
LinuxDeploy can use framebufer, but I can't mde it to work.
If what I was told is accurate, no one has written a framebuffer driver for at least pure-console Linux. Might this be the issue?

Well, I get the Idea how to test FB from LinuxDepoy's FAQ. The initial problem still exists, black screen while using fb.
Reply
#18
(05-07-2018, 09:14 PM)dguidi Wrote: However, you will have to root your Android to be able to mount it (you can find information about how to root Android here: http://support.planetcom.co.uk/index.php...i_Firmware).

The page is missing the info how to root a dual boot setup:


Either use the flash tool to write into "boot" the "patched_boot.img" instead of the default "boot-verified.img"


Or edit the Scatter-loading File "Gemini_Dual_Boot.txt" to use "patched_boot.img":
- partition_index: SYS23

  partition_name: boot
  file_name: patched_boot.img


Probably the partitionTool page should be updated to have a "root" option.

Regards,
Dietmar
Reply
#19
(05-17-2018, 12:05 PM)Beiriannydd Wrote: I added the following to my .bashrc in termux to make getting into linux easier.

linux() {
 su -c "/data/data/ru.meefik.linuxdeploy/bin/linuxdeploy shell -u gemini"
}

I also edited /data/data/ru.meefik.linuxdeploy/env/include/core/net/deploy.sh

### insert this bit
   echo "cleanup symlink resolver"
   test -L "${CHROOT_DIR}/etc/resolv.conf" && rm "${CHROOT_DIR}/etc/resolv.conf"
### before this line
   printf '' > "${CHROOT_DIR}/etc/resolv.conf"
   for dns in ${dns_list}
   do
       echo "nameserver ${dns}" >> "${CHROOT_DIR}/etc/resolv.conf"
   done

which allows the system to update the resolv.conf so that it can use DNS

Thank you for this, very helpful.  How to I fix my nameservers when I change from e.g. wifi to mobile data within the chroot?

edit:
solved.
there is a setting in linux deploy - "track network changes".
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)